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1 电磁分析对整车建模的基本要求 

几何模型简化：电磁仿真的基本原则是保留影响场强分布的结构，金属件对电磁场影响较大，

因此需要将主要的金属件保留。金属件的厚度通常是 mm 级的，因此金属件模型需要去除

厚度，可以避免两层网格，提高仿真效率。这其中也有特殊的情况，会保留介质部分例如：

玻璃天线，镀膜玻璃、前后保塑料件透波等。 

网格类型：Feko软件采用 RWG基函数，其核心算法为积分方程方法，主要有矩量法（MoM），

自适应矩阵压缩（ACA）及多层快速多级子算法（MLFMM）。矩量法和多层快速多集子算法

采用表面积分方程，只需要对物理表面进行剖分。物体表面采用平面三角形网格划分。 

 

图 平面三角贴片 
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图 RWG 基函数 

电磁网格尺寸：200MHz 以下建议采用 50mm 划分，当模型中有精细结构的模型，需局部加

密网格（按照＜50mm 划分网格）；频率高于 200MHz 时，高频段建议采用 1/8 波长划分模

型，并且其中最大的网格＜1/3 波长。电磁网格划分尺寸两个要求：仿真频率的波长、网格

能够拟合几何外形。矩量法与多层快速多极子求解器需要网格按照波长划分时，仿真效率高，

因此需要不同频段分段划分网格，下图是车上天线的工作频率。 

 

图 网格划分尺寸与频率关系 
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具体地说，不同频段对应的网格尺寸要求可以参考下表。 

表 汽车模型网格划分策略与求解器选择建议 

频段 网格尺寸 最大网格 网格质量 求解器 典型应用 

400MHz 

50mm 

(数量＜8

万) 

＜150mm 

网格最小角

度>20° 

（允许少量

最小角度≮

1°） 

 

MOM 

（频率＜10MHz，

选双精度） 

电磁兼容 

遥控钥匙 

胎压检测 

AM/FM 天线 

400MHz- 

1GHz 
35mm ＜100mm MLFMM 3G/4G 

1-2GHz 18mm ＜50mm MLFMM 
GNSS 

4G 

2-4GHz 9mm ＜25mm MLFMM 5G/BLE /WiFi 

4-6GHz 6mm ＜16mm MLFMM 5G/V2X 

6-8GHz 5mm ＜12mm MLFMM UWB 

电磁网格检查：重叠的三角形，孤立的三角单元，网格干涉情况不允许计算。三角单元最小

角度＞20°，允许少量最小角度≮1°。 

2 电磁分析相关几何模型的准备 

2.1 电磁分析关心的零部件 

电磁效应一般只由金属件产生，主要考虑整车中的金属件。也有例外情况，如涉及到局部天

线仿真时，当附近有玻璃，尤其是镀银玻璃时，需要保留玻璃进行分析。 

表  电磁分析中整车零部件是否保留的处理方式 

子系统 部件 处理方式 

所有塑料件、发泡件 删除 

车身 

白车身（钣金件） 保留 

白车身（压铸件） 保留 

挤压结构件 保留 

玻璃 保留 

四门两盖 保留 

IP 横梁 保留 

焊点、焊缝、胶粘信息 删除 

天窗金属框架 保留 

底盘 

前副车架 保留 

前悬架 保留 

转向系统 保留 

后副车架 保留 
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后悬架 保留 

轮毂 保留 

空气悬架储气罐 保留 

动力总成 

发动机/增程器 保留 

变速箱 保留 

传动系统 保留 

油箱 保留 

空调压缩机 保留 

N 合一电驱动 保留 

电池包 保留 

外装的控制器部件等 删除 

座椅 
座椅骨架、背板、轨道等 保留 

座椅发泡 删除 

内外饰 塑料、发泡、皮质、木质件 删除 

电子电器 
线缆 挑选关注的保留 

小蓄电池 保留 

*备注：处理模型时以上部件均保留，可以根据分析问题的类型，合理删除无影响或者影响

小件，以提高仿真效率。 

 

2.2 准备几何模型 

2.2.1 删除不必要的件 

上游的几何模型通常由 DRE 发送至电磁分析部门或者在 TeamCenter 中获得，但这些几何

文件通常包含了很多不必要的附件，如塑料件、螺栓螺母、发泡件、内外饰件等，这时候就

需要将这些不相关的零件删除，最终留下电磁分析需要用到的零件。 

这个删除工作可以在 CATIA 中手动操作，等删完再导出成 CATProduct 和 CATPart 文件，最

后导入到 HyperMesh 后再做下一步的建模工作。 

该工作也可以通过二次开发自动化。建议提前和 DRE 协商命名规则（如在零件命名中添加

“发泡/塑料/螺栓”等材质信息），后续在 CATIA 或 HyperMesh 中，通过二次开发的关键词匹

配，找到对应的零件并批量删除之。这部分功能，有需要可以联系我司协助开发。 

此外，由于电磁分析专业的工程师对于整车零部件材质通常并不熟悉，这时候需要跟 DRE 紧

密沟通，避免不相关的零部件被划为网格参与电磁计算。典型的如座椅内部的塑料板被当做

金属板，车身上的塑料覆盖件被作为钣金件参与计算等。 

2.2.2 螺栓孔的简化 

针对金属件的螺栓孔，原则上无论大小都应该全部填充。因为过孔螺栓本身就是金属件，螺

栓本身就相当于填孔的作用。 
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螺栓孔的填孔可以基于几何填孔，也可以基于网格填孔（hole&gap fill 功能）。建议在几何

层面完成。 

针对钣金件几何的填孔，可以通过 BatchMesher 中 parameter 文件关于孔简化的规则来去

除，也可以通过 2D => Surface => Patch 来实现填孔。 

  

图 几何填孔的效果 

 

3 电磁分析整车建模流程 

删除不相关的零件之后，电磁分析的整车建模主要剩下两个关键的步骤：一是各零件的网格

划分；二是对各自划分后的零件，进行网格的连接（共节点）。这两个步骤都可以在HyperMesh

中完成，并且各自都有多种工具（适用于不同的零件类型）可以选择。总得来说，步骤一可

以用一些自动化的工具，而步骤二则基本需要手动操作。 

如前所述，因整车电磁分析针对的频段不同，需要得到不同尺寸（6mm, 9mm, 15mm, 25mm, 

50mm, 65mm）的整车有限元网格模型。这时候就有两种思路，一是对于每一个尺寸，都从

几何文件开始做网格划分和网格连接，这样无疑是最耗时间，虽然精度稍好但是对于大尺寸

网格来说并无必要，故不推荐。二是选择其中某个尺寸作为基准尺寸，先通过网格划分+网

格连接，做出这一套基准尺寸的网格，然后再通过网格重画（Remesh）的功能，将该基准

尺寸网格重画为其他的尺寸。结合我们的工程实施经验，推荐大家先做 15mm 作为基准网

格，再通过重画，形成其他尺寸的电磁网格。基于此，总体的电磁网格划分流程见下图。 

需要说明的是，有的零件如座椅部件、IP 横梁等，因为本身几何尺度较小，不适合划分太大

尺寸的网格，故在大尺寸网格分析中，这些零件仍使用 15mm 或 25mm 的网格参与分析。 
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图 电磁网格划分流程 

此外还需要注意，当 15mm 基准网格往小重画时，可以借助 HyperMesh 的 Remesh 工具

重画，而当往大重画时，建议直接使用 Feko 中的 Remesh 工具，实测下来，Feko 的

Remesh 工具对于大网格的适应性会更好。 

4 常见的建模及连接方法介绍 

前文提到，删选出必要的几何后，主要的工作剩下两步：一是网格划分（建模），二是网格

连接。HyperMesh 中提供多种工具，用户需要熟悉每种工具分别适用的零件类型/零件形状

并加以练习，从而提高建模效率。 

从各零件的特点出发，可以将几种网格划分和连接方法的适用情况列表如下。 

表 整车电磁建模中关心的零部件及其推荐的网格划分和连接方法 

 

下面分别介绍电磁网格划分和网格连接的几种方法的具体操作。 

BatchMesher

批处理网格

手动

Midsurface

+2D Mesh

手动取表面

+2D Mesh

+手动补面

MidMesh

中面网格

Shrink Wrap

包覆面

手动构造

几何

+2D Mesh

Midline取

中线

+画1d网格
白车身（钣金件） ●
白车身（压铸件） ◎ ●
挤压铝等 ●
四门两盖 ●
IP横梁 ● ◎
副车架 ● ◎铝制
悬挂 ● ◎铝制
转向系统 ●
轮毂 ●
N合一电驱动/发动机/增程器 ●
变速箱 ●
传动系统 ●
油箱 ●
空调压缩机 ●
电池包 ◎ ●
座椅骨架 ●
座椅钢丝 ●
线缆 ●
小蓄电池 ◎ ●

● ◎ 表示备选方法表示默认方法

优先级：
2.1 Fuse缝合
2.2 Ruled补面
2.3 Imprint压印并连接
2.4 手动共节点+创建单元

2. 网格连接方法选择

电子电器

底盘

动力总成

子系统 部件

车身

1. 画网格方法选择

座椅
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4.1 电磁网格划分（建模）的几种常见方法 

本文主要使用 HyperMesh 有限元前处理软件进行电磁网格建模，因 HyperMesh 是求解器中

立的前处理工具，针对各类第三方有限元求解器如 OptiStruct、Nastran、Abaqus、Feko 等

均可以进行建模。因本手册针对高频电磁建模，本文中将使用 HyperMesh 的 Feko 模板进

行演示。  

 

图 HyperMesh 中的 Feko 求解器模板 

相应地，导出的文件类型为*.fhm，可直接在 Feko 软件中读取。 

 

图 导出*.fhm 格式的求解文件 
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针对电磁网格划分，HyperMesh 中常见方法有： 

4.1.1 BatchMesher 批处理网格 

BatchMesher 是 HyperMesh 中的一个子程序，具有单独的软件界面。其核心是对于给定的

几何文件，全自动化地对其抽取几何中面，并对抽取后的中面划分网格。也正因为其需要抽

取几何中面，故主要适用于白车身钣金冲压件。 

BatchMesher 每个 CPU 只处理一个钣金件，用户可以设置多 CPU 并行处理，可以极大提高

划分效率。 

因 BatchMesher 批处理网格划分的流程篇幅较大，特在 5.1.1 小节进行详细说明。下图是

BatchMesher 主程序界面。 

 

图 BatchMesher 划分状态 

4.1.2 手动 Midsurface+2D Mesh 

Midsurface 是 HyperMesh 中的一个抽取几何中面的功能。熟悉 HyperMesh 的用户可能知

道，在 HyperMesh 中抽取中面有多种方法，如 offset/planes/sweeps/skin offset，以适用多

种类型的零件，而在前面第 1 种方法 Batchmesher 中，只能指定其中一种方法（对于车身钣

金件，通常使用 skin offset 方法），该 skin offset 方法对于挤压铝的中面抽取通常效果不佳，

故对于这些数量不多的挤压件，可以由用户手动 Midsurface 指定对应方法抽取中面，并随

后创建 2D Mesh。 

如下图所示的某挤压铝件，首先抽取其中面。左边是原始 CAD，右边是抽出来的中面几何。 
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图 某挤压铝件的手动 Midsurface 

手动抽取 Midsurface 工具的入口为 HyperMesh => 2D => Midsurface。打开其拓展选项，

其中的 Midsurface method 设置为 Planes + Sweeps + Offsets，这样含有内部结构的挤压铝

零件即可抽取中面。 

 

图 抽取中面选项说明 

此时抽取出来的中面其实保留了所有特征线，若两条特征线挨得很近，则后续划分网格的

时候容易出现很窄的单元，这些单元质量很差，计算结果不可靠。为了避免这些情况，需

要抑制一些特征线，可以使用 Batch Cleanup 工具来清理中面几何。 



澳汰尔工程软件（上海）有限公司 

12                                            澳汰尔中国区技术支持邮箱：support@altair.com.cn 

 

图 Batch Cleanup 工具的入口 

该工具需要 parameter 和 criteria 文件的输入，即上一节《BatchMesher 批处理网格》中用

到的两个文件。因为 parameter 文件中定义了几何清理的选项，经过 Batch Cleanup 之

后，即可得到清理后的几何。其效果如下图所示 

 

图 Batch Cleanup 之后的挤压铝件特征线效果 

从上图可以看到，不仅结构的特征线被大量抑制，并且模型中的圆角也被简化为直角。这

样就可以避免后续画网格，尤其画大尺寸网格中网格质量较差的问题。 

此外，对于中间的加强面，如果该件属于闭口件，建议将中间面删除，避免内部网格的重

复计算，如下图。 
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图 删除内部多余的面 

4.1.2.1 参考模型 demo 

原始模型：…\ 00_HyperMesh for Feko\00_Models\ 2_MidSurface_Absorber Beam_Start.hm 

完成的模型：…\ 00_HyperMesh for Feko\00_Models\ 2_MidSurface_Absorber Beam_Done.hm 

 

图 手动 Midsurface 模型 demo 效果 

4.1.3 手动取表面+几何清理+2D Mesh  

对于没有明显板壳特征的单个零件，如铝制摆臂等是无法抽取中面的，此时可以选择直接手

动选择零件外表面并划分 2D Mesh。 

若原几何是体 Solid，可以直接删除 Solid 但是保留外表面，选中体之后，按键盘上的 Delete
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件，下图所示弹窗中，Delete associated surfaces 不勾选，以保留外表面。 

 

图 删除体时的保留外表面选项窗口 

得到外表面之后，一般会存在很多特征线，此时可以使用 Batch cleanup 功能（入口在

Topology=> Edit => Defeature=>Batch）来抑制过多的特征。其实 BatchCleanup 可以看做

BatchMesher 的轻量版，其只做几何清理，后续还需要再进行 2D Mesh。用户也可以直接

取外表面之后，用 BatchMesher 来同时完成这两步操作。 

   

左：原 solid        中：取外表面      右：Batch cleanup 后效果 

图 铝制下摆臂取表面+几何清理的效果 

使用 2D Mesh（2024 版本功能入口 2D=>Surface Mesh=>Freeform，2023 版本功能入口

2D=>Surface Mesh=>General 2D Mesh），生成三角形网格后，效果如下左图所示。需要

注意的是，此时摆臂两端套筒的厚度较薄，内外两片网格之间间隔太近，为了避免这种情

况，可以选择直接将两端套筒删除，或者将其中内筒网格删除。可以看下右图，上部套筒

被删除，下方套筒的内测网格被删除，用户可以自行按需选择哪种方法。 
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图 摆臂两端套筒的处理办法 

4.1.3.1 参考模型 demo 

原始模型：…\ 00_HyperMesh for Feko\00_Models\ 3_Outside Surf_Low control arm_Start.hm 

完 成 的 模 型 ： …\ 00_HyperMesh for Feko\00_Models\ 3_Outside Surf_Low control 

arm_Done.hm 

 

图 手动取表面 demo 模型效果 

4.1.4 MidMesh 中面网格 

MidMesh 是 HyperMesh 中的一项重要功能，它主要面向具有较多筋肋结构的铸造件，包括

塑料注塑件和铝制铸造件。该工具是为了弥补 midsurface 工具无法在这种复杂筋肋结构抽

取中面几何而开发的，它可以直接在大板、筋肋结构的中间位置直接创建壳网格。 
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图 MidMesh 划分中面网格的效果 

在电磁分析中，主要是铝制铸造件需要用到中面网格，典型的零件如铝减震塔。MidMesh

可以将铝减震塔的筋肋较好地保留。MidMesh 抽出的中面网格通常需要大量时间手工修

复，其入口为 2D => Surface Mesh => MidMesh，包含很多子功能，因为功能很多，且图

形交互太多，建议大家移步观看视频学习 https://www.bilibili.com/video/BV16x4y1z7KK。 

对于大型铝制压铸件，其外表面通常比较复杂，且加强筋肋太多，若直接进行 MidMesh 也

会耗费大量时间。故对于大型压铸件，进行必要的结构简化是必须的。我们建议：通过手动

创建点-线-面，将压铸件外形特征勾勒出来，具体的操作，可以参考 5.2.2 悬挂上摆臂的简

化章节。 

4.1.5 Shrink Wrap 包覆面 

对于较为复杂的零件总成，如发动机变速箱总成、N 合一电驱动总成，将其详细建模是很困

难的，而且对于电磁分析来说也务必要，因为电磁分析只关心外部的电磁反射面，故用户只

需要得到一个零件总成的粗略外表面即可。这里 HyperMesh 提供了专门的包覆工具 Shrink 

Wrap，其效果如下图所示。 

 

图 Shrink wrap 包覆面效果 

该工具的用法简单，只要给定输入的部件（即总成几何），并设置目标单元尺寸，即可一键

创建外表面的网格。工具入口位于 2D=>Surface Mesh => Shrink Wrap。
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图 Shrink Wrap 工具的使用 

关于包覆效果的宽松/紧密效果的差别，可以看下面两张图的对比。可以看到紧密 Tight 

wrap 会保留很多局部凹凸特征（对电磁分析务必要），故建议使用宽松 Loose wrap。 

 

图 Shrink Wrap 中宽松/紧密包覆效果 

需要注意的是，此时生成的外表面网格为四边形，而 Feko 电磁分析统一使用三角形网格。

所以完成包覆网格后，需要使用 2d=> edit elements => split(plate)工具将四边形单元劈开

成三角形单元，如下图。 
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图 Split 工具劈开四边形单元为三角形单元 

 

图 HyperMesh 将四边形单元劈开成三角形单元之后的效果 

除了 split 工具劈开，也可以选择 Freeform 重画网格，在 5.3.1 小节中有相关说明。 

另外需要注意的是，包覆之后，内部的空腔也会产生网格，这些网格对于电磁分析来说是

多余的，需要手动删除之，可以参考 5.3.1 小节的相关描述。 
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4.1.5.1 参考模型 demo 

原始模型：…\ 00_HyperMesh for Feko\00_Models\ 5_Shrink Wrap_Start.hm 

完成的模型：…\ 00_HyperMesh for Feko\00_Models\ 5_Shrink Wrap_Done.hm 

 

图 shrink wrap 包络模型 demo 效果 

4.1.6 手动构造几何+2D Mesh 

另外有某些特定的复杂零件如转向系统，通常既无法抽取中面，也无法有效拾取外表面，包

覆效果也不好。针对这种零件，可以通过手动构造几何（圆柱、球体等）来创建其电磁反射

面。 

 

图 某转向系统 

手动构造几何的效果，参考下图，即两者的空间位置、覆盖区域基本相同，取表面划分电

磁网格后，电磁响应也基本相同。 
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图 转向系统手动构造简单几何 vs. 原几何 

这一部分的手动操作篇幅较大，可以参考第 5.2 节转向系统部分的详细说明。 

 

图 转向系统上半部分划分网格效果 

手动构造几何的应用场景还有很多，如下各图。 
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图 手动构造几何，具体操作请参考 5.1.2 小节 

 

图 手动构造几何，具体操作请参考 5.2.2 小节 

4.1.7 Midline 取中线+画 1d 网格 

针对通信线缆或者高压电缆，通常使用 1d 网格来模拟其电磁响应。因为 CAD 模型中通常只

有实体的电缆，故可通过 HyperMesh 中的 Midline 功能，抽取实体电缆的中线，然后再对该

中线划分 1d 网格。 

如下图所示电缆部分，使用 Midline 功能抽取后，效果如下图所示。 
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左：原电缆几何                       右：抽取后的电缆中线 

图 Midline 抽取中线  

汽车座椅的钢丝，也可以用相同的方法： 

  

图 座椅钢丝 Midline 抽取中线前后效果 

得到抽取后的中线， 继续划分 1d 网格。这里需要说明的是，Feko 软件中支持导入

Nastran 格式的节点坐标，所以这里 HyperMesh 的求解器模板需要切换成 Nastran。为了

避免求解器模板切换导致的其他单元类型混乱，建议用户针对电缆单独开一个 HyperMesh

操作。 
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图 HyperMesh 切换求解器模板 

接下来通过 1D=>Line Mesh 来创建电缆的 1d 网格。用户可自定义划分的网格尺寸。创建

时，还需要点击 Edit Element Category，将创建的单元类型改成 Beam（1D），如此，单元

才可以被 Feko 软件（cable-import from file）识别。最后将生成的 1d 单元导出成*.nas 

（不能是.bdf，因 Feko 不识别）文件即可。 

 

图 Line Mesh 创建 1d 网格并更改单元类型 
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4.1.7.1 参考模型 demo 

原始模型：…\ 00_HyperMesh for Feko\00_Models\ 7_1d Mesh_Start.hm 

完成的模型：…\ 00_HyperMesh for Feko\00_Models\ 7_1d Mesh_Done.hm 

 

图 抽中线划分网格 demo 效果 

4.2 电磁网格连接的几种常见方法 

上一节介绍了部件各自的网格划分方法，划分之后还需要进行部件之间的共节点连接以保证

电连续性。当然部件之间的连接需要根据实际的连接情况来，如焊点、焊缝、螺栓等。 

HyperMesh 中针对电磁网格连接的常见方法有：Fuse 缝合、Ruled 补面、Imprint 压印连接、

手动共节点+创建单元等。下面分别作介绍。 

4.2.1 Fuse 缝合 

Fuse 工具是 HyperMesh 中专门针对电磁网格连接开发的工具，它可以方便地为两个件之间

创建共节点连接。 

 

图 Fuse 工具操作前后效果 
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Fuse 工具的入口为 2D=>Fuse。 

 

图 HyperMesh 中 Fuse 工具入口 

Fuse 工具下有 Open Shells 和 Closed Shells 两个选项，通常我们处理的都是开口壳体，故

选择 Open Shells 即可。 

 

图 Fuse 工具的选项 

Fuse 工具的选项如上图所示，需要特别注意的有三点： 

1. 起始件和目标件的选择，可以选择部件 component，也可以选择单元 elements，通常

来说选择 component 即可，但对于一些特殊位置如后尾门，为了防止误连接，建议直

接选择法兰面部分的 elements 作为起始面； 

2. Fuse free edges only：若勾选，则连接只会从自由边开始，不适合具有法兰面的两个

件连接；不勾选时，可以针对法兰搭接面实现共节点并删除重复搭接面，如下图。 
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Fuse 缝合法兰搭接面的效果（法兰面搭接面删除其一） 

3. Bridge gaps：若勾选，则会在起始件和目标件的间隙中创建新的单元以连接两个部

件，若不勾选，则会直接将起始件的边界网格缝合至目标件上。建议两件缝隙较小

时，不勾选该选项； 

4.2.2 Ruled 补面 

Ruled 补面工具，常用于两件之间存在较大缺口的情况。通过选择分属两个件的两排节点，

即可在中间创建出连接用的单元。如下图所示。 

 

图 Ruled 工具效果 
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图 Ruled 工具的使用 

Ruled 工具在 HyperMesh 软件中的位置是 Topology=>Ruled，使用 Ruled 工具时，默认对

象是 Locations，将其切换为 Nodes，然后一次选择两侧的节点即可。选择节点时，可以按

住 Alt 键点选首尾两个点，即可按照 by path 的方法，沿着首尾的路径选择一排节点。Alt

键+左键其实是快速选择，可以在空白区右键=>select=>configure Alt+Select 来配置默认

的快速选择模式，对于节点 nodes，默认的就是 by path，即沿路径选择的方法。 

 

图 HyperMesh 中 by path 选择一排节点 

另外需要注意的是，Ruled 工具默认创建的单元类型和 General 2D Mesh 工具相同，所以

如果默认的单元类型是 Mixed，就会出现 Ruled 工具创建出来为四边形单元的情况，此

时，需要使用 General 2D Mesh 工具用三角形单元划分一次网格，从而更改默认单元类

型，而后用 Ruled 工具也会统一创建三角形单元。 
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图 在 General 2D Mesh 工具中将默认单元类型设置为 Trias 即三角形单元 

当然，如果已经创建了四边形单元也不必担心，HyperMesh 中的 Split 工具可以将四边形单

元劈开成三角形单元。 

如下图，通过 2D => Edit Elements => Split 工具，选择对象为 Plate，然后点选 Elements

旁边的…图标打开高级选项，再选择 By Config 通过单元类型选择，勾选所有的 CQUAD4

单元即可选中所有的四边形单元。 

   

图 Split 工具劈开模型中所有的四边形单元 
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劈开四边形单元也有很多劈法，用户可以切换其中不同的方法预览并执行 Split 操作，参考

下图。 

   

 图 Split 工具劈开单元的选项效果 

4.2.3 Imprint 压印并连接 

有时候碰到管件尾端和另一平面需要连接的情况。在 HyperMesh 老界面中，有 extend 功

能，而在当前的 2023 版本 HyperMesh 中，该功能已经被移植到 Imprint 功能中，其效果如

下图。 

 

图 Imprint 并创建连接 

功能入口位置在 HyperMesh=>2D=>Imprint。注意选择 target 对象为单元，选择 source 对

象为 Node list（非 nodes）。 
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图 HyperMesh 中 Imprint 工具入口 

 

图 Imprint 工具需要关注的选项 

Imprint 工具需要关注的控制选项有两个，如上图的标注 1 和 2。 

首先看标注 1，该选项控制在连接部件之间是否新生成单元，各选项的效果差别，可以直

观地看下图。 

 

图 Imprint 工具的 post imprint options 选项差别 

对于标注 2，是控制选择的节点是否首尾相接，其效果在标注 2 中已经贴图说明。 

4.2.4 手动共节点+创建单元 

手动共节点即时将两个原来分开的节点合并，它的缺点是只能一个个地共节点，效率最慢，

但是同时也几乎是适用于任何连接场景的。当前面几种连接方法无法创建连接或者连接效果
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不好时，手动共节点就是最后的保底方案。 

对于零星几个点的处理，用手动共节点也是很方便的。如下图，需要将红色点共节点至紫色

点。 

   

图 共节点的使用场景 

共节点工具的入口在 2D => Edit Element => Replace。可以单点对单点共节点，也可以多点

对多点，用户切换导航条中的 One to One 为 Multi to Multi 即可。此外，导航条右侧的选

项中的 Equivalence 需要勾选，意为两节点合并。而 Replace at midpoint 为可选操作，意为

合并后的位置在两输入节点的中心位置。 

 

图 共节点 Replace 工具在 HyperMesh 软件中的入口 

除了共节点，上述工具界面下还有一个 Create 工具比较常用，它的功能是手动创建单元，

用户可以直接点选空间中的三个点，即可直接创建三角形单元。 

如下图模型中有个缺口需要补全，选择三个节点后，直接按鼠标中间，即可创建三角形单

元。HyperMesh 默认为结构单元创建四边形单元，如果用户点选四个节点，即可自动创建

四边形单元，而创建三角形单元时，就需要手动按中键确认操作。 
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图 手动创建单元的使用场景 

4.2.5 参考模型 demo 

原始模型：…\ 00_HyperMesh for Feko\00_Models\ 1.2_Mesh_Fuse_Edit_IPBeam_Start.hm 

完成的模型：…\ 00_HyperMesh for Feko\00_Models\ 1.2_Mesh_Fuse_Edit_IPBeam_Done.hm 

 

图 IP 横梁局部模型 demo 效果 

4.3 利用对称性减轻工作量 

因为部件网格互相连接的工作量很大，且白车身中大部分部件都是左右对称的，如果左右都

需要各自共节点连接，则费时间又无必要。我们可以先做左边的网格连接，然后通过镜像网

格生成右边的部分。这不仅使用与车身，还适用于座椅、悬架、轮胎等结构。 
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图 挑选左边的零件，以及中间的连接件 

先画左侧的网格后，通过 Topology-FE Geometry-From CAD 将当前的 CAD Geometry 转化

为 FE Geometry。然后再通过 Split 切割工具，将车身从中间位置切开。 

 

图 从 y 轴位置中间切割 

然后再镜像即可。镜像后可以通过 equivalence 操作使镜像面上的节点融合。 
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图 镜像操作 

 

图 镜像后的整车模型 

 

图 对镜像后的模型进行节点融合 
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5 各子系统（15mm 网格）的建模及连接 

5.1 车身的建模及连接 

5.1.1 白车身（钣金件） 

5.1.1.1 BatchMesher 批处理网格划分 

白车身中包含数百个钣金件，使用 BatchMesher 批处理网格划分工具可以显著提高网格划

分效率。本章节将介绍白车身上钣金件的 BatchMesher 网格划分方法，此方法的特点是提前

准备好几何、网格划分标准文件和网格质量检查文件后，无需人为操作，在简单的 5 分钟内

完成设置后，自动完成几百个钣金件的网格自动划分。 

1. 准备单元尺寸为 15mm 的 BatchMesher 网格划分标准文件，命名为 feko_15.param（随

文附送：…\00_HyperMesh for Feko\00_Models\10_BatchMesher_Parameter_Criteria 目

录下），该文件可以在 HyperMesh>Topology>Param/Criteria 中编辑和另存。 

 

 

图 feko_15.param 文件内容 

2. 准备单元尺寸为 15mm 的 BatchMesher 网格质量检查文件，命名为 feko_15.criteria（随
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文附送：…\00_HyperMesh for Feko\00_Models\10_BatchMesher_Parameter_Criteria 目录

下）。该文件可以在 HyperMesh>Topology>Param/Criteria 中编辑和另存。 

 

图 feko_15.criteria 文件内容 

3. 准备清理后的几何文件，并将几何导入 HyperMesh，清理后的几何仅保留必要的钣金件。 

 

图 导入后的车身几何 

4. 为提高 BatchMesher 的并行效率，在 HyperMesh 中运行分 component 的 tcl 脚本，每

个 component 会生成 1 个 hm 后缀文件，所有 hm 文件在一个文件夹。 

4.1 编 写 tcl 脚 本 ， 命 名 为 split.tcl （ 随 文 附 送 ： …\ 00_HyperMesh for 

Feko\00_Models\11_Split tcl 目录下）。实现 component 重命名和每个 component 保存

为一个 hm 文件 
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将当前模型分 component 输出 hm 文件的脚本 

   4.2 在第 3 步中的 HyperMesh 模型上运行 split.tcl。 

 

图 HyperMesh 中运行 tcl 脚本 

4.3 脚本运行完成后，将在指定的~BatchMesher_BIW 文件夹得到多个 hm 后缀的模型

文件。 
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图 脚本运行后生成的 hm 文件列表 

5. 打开 BatchMesher 提交界面。 

 

图 BatchMesh 程序入口 
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图 BatchMesher 主程序 

5. 在 BatchMesher 的 Run Setup 页面设定参数。 

5.1 设定 Input model directory 为第 4.3 步指定的 BatchMesher_BIW 文件夹 

 

图 设定输入文件夹地址 

5.2 在模型输入文件夹下选择要划分网格的模型 1）点击右侧的 Select Folder with 

Model File；2）设置 Type of geometry 为 HyperMesh ; 3)点击 Select。 
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图 在 BatchMesher 中选择输入的文件 

5.3 设定完成后，会得到下边一行数据 

 

图 选择输入后的界面 

6. 在 Batchmesher 的 Configurations 页面添加标准文件，即添加第 1 步的 feko_15.param 和

第 2 步的 feko_15.criteria。 

6.1 点击 Configurations 

 

图 BatchMesher 的 Configurations 页 

6.2 添加一行，并添加标准文件。1）点击右侧 Add Entry；2）新增这行的 Mesh Type

列，命名为 feko_15; 3) Criteria File 列，点击该空格，然后去点击 Find Criteria Param File,选

中 feko_15.criteria；4）Parameter File 列，点击该空格，然后去点击 Find Criteria Param File,

选中 feko_15. Param。 
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图 选择 criteria 文件 

6.3 设定完成后会得到如下设置 

 

图 设定新的 BatchMesher 配置 

7. 回到 BatchMesher 的 Run Status 页面，设定 Mesh Type 为 feko_15。 

 

图 设定 BatchMesher 划分方法 

8. 设定输出和运行相关参数，1）设定输出文件夹为~BatchMesher_BIW_meshed，某指定文

件夹，生成的画完网格的 hm 文件会在这个指定文件夹；2）设定 Number of CPU 个数，代

表了并行划分网格的任务个数。3）Submit 提交任务。 
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图 设置输出文件夹及 cpu 并行数量 

9. 任务提交后，可在 BatchMesher 的 Run Status 页面查看运行进展。最后几行任务，在 Status

列全显示为 Done，代表网格划分完成。 

 

 

图 BatchMesher 运行状态列表 

10. 在结果输出文件夹，即第 8 步中指定的文件夹~BatchMesher_BIW_meshed，可以得到网

格划分完成的网格模型，以及汇总数据，示例模型有 116 个零部件，用 8 个 CPU 并行，在

22 分钟完成网格划分。 
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图 BatchMesher 状态记录 log 

11. 将~BatchMesher_BIW_meshed 文件夹下，划分完成的 hm，导入到一个 hm 文件中。 

11.1 新开空白 HyperMesh 界面，file>import>~BatchMesher_BIW_meshed>选择第一个

hm 文件，再按 shift+选择最后一个 hm 文件，实现选择所有 hm 文件，点击 打开>import 

 

图 HyperMesh 中导入所有 BatchMesher 划分后的的 hm 文件 

11.2 导入完成后，按快捷键 F，使模型居中显示。 
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图 导入后的有限元模型 

13. 按照指定网格质量检查项，可视化模型的网格质量。 

13.1 在 HyperMesh 主菜单 Topology>Setup 组>Param/Criteria>Criteria Editor 中配置

质量检查文件。按下述选择第 1 步中的 feko_15.crireria,点击打开，点击 OK。 

 

图 HyperMesh 中网格质量标准设定 

13.2 在 HyperMesh 底部工具的 Face Color 中，取消 Automatic，选择 Element Quality。

图形去显示已有的 32.87 万网格，不达标网格质量个数为 242 个，约占 0.1%。一般来说

BatchMesher 得到的网格质量都较好，如有局部的网格质量极端差的情况，可以使用 2D => 

Edit Elements 中的各项工具进行局部调整。 
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图 当前模型网格质量视图 

5.1.1.2 网格连接 

BatchMesher 划分后网格后，各钣金之间的连接关系（即共节点）还需要逐一处理。手动共

节点（快捷键 F3）的效率很低，只适用于局部位置的处理，推荐读者使用 Fuse 功能先进行

大面的连接。在局部位置 Fuse 可能效果不好，这时可尝试使用 4.2 节中其他几种方法连接。 

Fuse 的操作通常无法批量多对多连接，对于白车身几百个钣金件来说，一对一地选择 Fuse

对象也存在效率低下的问题。一种可行的办法是通过二次开发，逐个自动选择 Fuse 对象，

人工只在每次 Fuse 完成后检查 Fuse 效果（若好则继续，若不好则回撤或跳过），这里需要

注意的是 Fuse 对象件即 Target 和 Source 的顺序选择，有的局部位置 Fuse 失败，但是对换

Target 和 Source 件即能成功。这方面澳汰尔二次开发团队可以携手各大主机厂建立 Fuse 自

动化能力，可联系 support@altair.com.cn。 

下面，我们已白车身的 B 柱为例，简单地演示创建钣金件车身的连接。 

首先，我们删除不必要的内部加强件 

mailto:可联系support@altair.com.cn
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图 红色件（为了方便观察仅取了部分）为内部加强件，需要删除 

在 B 柱上方，我们首先将内侧两块板通过 Fuse 连接，可以发现两块板有较大面积重叠，首

先删除内板重叠的单元。 

 

图 删除两个件重叠的部分单元 

然后，通过 Fuse 功能将两者连接起来，注意在选项中，不要勾选 Bridge Gaps。 
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图 B 柱内板 Fuse 前后效果 

然后，我们将 B 柱上部内外板进行连接。此时因为内外两块板有重叠的法兰面,注意取消勾

选 Fuse free edges only。 

 

图 B 柱内外板 缝合的设置 

此时点击 Fuse 缝合，可以看到内板的法兰面被删除，缝合效果符合预期建模效果。 
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图 B 柱内外板缝合前后效果 

同样的，对 B 柱内外板进行缝合，其效果如下图所示。 

  

图 B 柱内外板进行缝合前后效果 
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其余操作类似，不再重复说明。 

5.1.1.3 参考模型 demo 

原始模型：…\ 00_HyperMesh for Feko\00_Models\ 1.1_BatchMesher_Door_Start.hm 

完成的模型：…\ 00_HyperMesh for Feko\00_Models\ 1.1_BatchMesher_Door_Done.hm 

 

图 车门 BatchMesher 模型 demo 效果 

5.1.2 白车身（压铸件） 

对于小型的压铸件，建议通过 MidMesh 的方法直接创建中面网格。 

  

图 通过 MidMesh 创建中面网格 

对于较大的压铸件（MidMesh 创建、修复时间均太长），或者使用 MidMesh 方法效果较差
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的件，可以通过手动构造几何的方法来建模。 

   

a. 原始几何                b. 取特征面            c. 通过几何工具修复面 

图 减震塔手动提取外表面后修复几何前后效果 

期间，使用了删除面，补面，延伸面等的操作。下面分别贴图说明。在 HyperMesh 中处理

几何相关的修复时，推荐读者将显示模式在 Component 和 Topology 之间切换，以实现最

佳的显示效果。 

  

图 HyperMesh 中的显示模式切换 

删除面。在选中几何面之后，直接按键盘上的 DELETE 键即可。 
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图 删除局部几何面 

补面。使用 2D => Surface => PATCH 

 

 图 补面  

延伸面。通过 2D => Surfaces => Cross Extend 功能，进行面的延伸。 

  

图 延伸面 
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将面修复完成后，直接通过 2D => Freeform 划分三角形网格即可。 

 

图 最终的三角形网格效果。 

5.1.2.1 参考模型 demo #1 

原始模型：…\ 00_HyperMesh for Feko\00_Models\ 4_MidMesh_Start.hm 

完成的模型：…\ 00_HyperMesh for Feko\00_Models\ 4_MidMesh_Done.hm 

 

图 Midmesh 模型 demo 效果 
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5.1.2.2 参考模型 demo #2 

原始模型：…\ 00_HyperMesh for Feko\00_Models\ 6.2_Manual Surf_Shocktower_Start.hm 

完成的模型：…\ 00_HyperMesh for Feko\00_Models\ 6.2_Manual Surf_Shocktower_Done.hm 

 

图 手动构造几何 demo 效果 

5.1.3 挤压铝材 

如下图所示门槛挤压铝（部分）。该挤压铝通常在门槛梁内部，对于电磁分析来说贡献很小，

且增加计算时长，对于这种件，可以直接删除。 

 

图 门槛梁内部挤压铝（部分） 

特殊情况下，有的铝型材能在车身外表面，如作为前舱加强框架、底盘加强框架时，则该

件对于电磁分析的影响不可忽略，此时，可以参考 4.1.2 小节，手动抽中面的方法处理。 

5.1.4 四门两盖 

四门两盖的操作总体上和白车身钣金件相似，其主要的问题在与包边处的网格处理。首先删
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除门板内部的加强梁等不必要的部件。然后通过 Batchmesher，创建其内外板的网格。 

下面的局部视图中可以看到包边的结构特点。 

 

图 完成 BatchMesher 后的门网格 

 

图 门的包边局部视图 

下面进行内外板的连接，照例我们使用 Fuse 功能，取消勾选 Fuse free edges only。建议设

置外板为 Source，内板为 Target。 
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图 门板的内外板设置 

Fuse 连接后，发现包边已经被删除，且内外板的网格实现自动连接。 

  

图 内外板实现网格连接效果 

门框和车身之间使通过支架连接，这方便内容可以参考下一节 IP 横梁中 IP 梁和其上支架

附件的连接。 

其余四门两盖的建模方法可参考其他章节，这里不再重复说明。 
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5.1.5 IP 横梁 

IP 横梁的参考模型如下： 

 

图 IP 横梁参考模型 

观察结构中钣金件较多。划分策略是，首先对各件抽中面+画网格，然后对各件做网格连

接。 

首先我们抽中面+画网格，IP 横梁中有多个钣金件，可以一次性通过 HyperMesh 界面中的

BatchMesh 来划分。使用我们提供的 Feko_15.param 和 Feko_15.criteria 文件操作。完成后

的效果如下图。 

 

图 IP 划分网格的效果 

需要注意的是，某些高端车的 IP 横梁是带横截面的铝合金型材件，用 BatchMesher 抽中面
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的时候，请将抽取方法选择为 offset+planes+sweep。 

上述网格还未连接，我们选取有代表意义的几处建立连接关系： 

一是横梁和右侧连接板之间的处理。 

 

图 IP 横梁和右侧连接板局部视图 

首先将多余的两排单元删除。然后通过 Fuse 功能缝合。效果如下图 

   

图 IP 横梁和右侧连接板的连接方法 

二是横梁和其上小支架的连接。为了便于观察，将小支架换了个颜色。针对这种几个节点

的连接，可以直接用 F3 快捷键手动共节点（参考 4.2.4 小节的介绍）。也可以通过 Fuse 处

理，Fuse 处理的设置如下右图，注意因为距离较近，不要勾选 Bridge gaps 
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图 IP 横梁和小支架连接关系的处理 

IP 横梁其他位置的连接处理方法类似，这里不再重复说明。 

5.2 底盘的建模及连接 

5.2.1 副车架 

典型铁质副车架如下图。铝副车架除了带起筋式加强的位置需要 MidMesh 来处理，其余位

置处理同铁质副车架。 

 

图 副车架图 

首先依然是 BatchMesher 抽中面+画网格。依然使用 Feko_15mm.param 及
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Feko_15mm.criteria 这两个文件来执行。执行之后的模型如下图所示，此时各部件之间的

网格是未连接的。 

 

图 BatchMesher 之后的副车架 

接下来对模型做连接关系。挑有代表性的位置描述如下。 

 

图 下文副车架局部位置示意 

对于左纵臂，使用 Fuse 功能为各部件之间创建自动连接。效果参考下图。 
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图 副车架局部 Fuse 连接后效果 

逐个部件连接后，发现有些位置的连接不尽人意，如下左图标注。首先，对于未连接位

置，使用 edit element => replace 功能，将两个相近节点合并。 

  

图 副车架模型局部单元编辑 

然后，将多余的一排单元选中后，键盘键 DELETE 之。选择的时候，可以使用右键菜单通

过 by path 方式选择，更加高效。 
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图 副车架模型局部单元编辑-2 

对于副车架内部的接口衬板，因其位于结构内部，可以直接删除之。 

 

图 内部衬板图示 

5.2.2 悬挂 

铁质悬挂系统的处理和上一节的副车架类似，这里不在重复说明。 

下图是一套铝制双叉臂悬挂。 



澳汰尔工程软件（上海）有限公司 

62                                            澳汰尔中国区技术支持邮箱：support@altair.com.cn 

 

图 双叉臂悬架连杆 

首先是上摆臂，可以看到结构内部有很多加强筋，这对于我们网格划分非常不利，且对电磁

响应影响很小。我们首先考虑如何简化几何。 

  

图 上摆臂内外结构视图 

简化几何的思路是，直接不考虑内部的加强筋，直接选取上表面几何并划分网格。但是因为

结构几何本身面片很碎，导致无法很快捷地选择上表面所有的 surface，这时候，我们可以

通过手动构造线、面来等效替代原几何。 

第一步创建个新的 component 用于存放新的几何面。 

第二步，通过 Topology => Create => 样条曲线的功能，创建上表面的特征线条。 
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图 创建上控制臂的特征线 

后续可通过 Topology =>Create => Ruled 功能，创建面。 

 

图 通过 ruled，线创建面 

将之前的特征线几何删除后，可以看到生成的面之间是红色（自由边）。这时需要通过

Topology =>Edit => Stitch 功能缝合曲面。 
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图 曲面缝合前后效果 

再往后的操作，就是通过曲面生成 2D 网格，这里不再赘述。 

以上是上摆臂的操作方法，下摆臂操作类似，这里不再重复。另外，对于铝制下摆臂，也

可以通过 4.1.3 小节手动取表面+几何清理+2D Mesh 中的方法划分网格。 

5.2.3 参考模型 demo 

原 始 模 型 ： …\ 00_HyperMesh for Feko\00_Models\ 6.1_Manual Surf_Upper control 

arm_Start.hm 

完成的模型：…\ 00_HyperMesh for Feko\00_Models\ 6.1_Manual Surf_Upper control 

arm_Done.hm 

 

图 上摆臂手动构造几何 demo 效果 

5.2.4 转向系统 

转向系统包含许多铸造件，且连接关系较复杂（焊接、齿轮啮合、万向节等），如果完全抽

取外表面则包含很多小特征，还需要做连接，工作量将很大且务必要。 
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这时候我们换个思路，可以用 HyperMesh 中的创建几何功能，利用如圆柱体、立方体等几

何来代替原来的转向管柱、转向助力器、齿轮齿条机构等，如果两者的几何相近，两者电磁

响应的差别是很小的。 

 

图 某转向系统 

首先在 Model Browser 中右键 Create，新建一个 component，暂命名为 NewSolid。可以看

到该 component 高亮，说明其是 current component，即默认新建的对象会被放到这个

component 中。 

 

图 新建 component 

创建圆柱体有两种方法，一是先画底面的圆，然后通过 Extrude 工具拉伸出体。这两个功

能都在 Topology 一级菜单下方，见下图。这种方法的好处是灵活性好，因为画圆的时

候，可以选择三点画圆。 
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图 Extrude 功能创建圆柱体代替圆部件 

二是从 3D => Solids => Cylinder 创建，该工具是一次性完成上面两步操作，但灵活性欠

佳。 

 

图 新建圆柱体 Solid 

创建体也是类似，可以分步骤拉伸创建，也可以通过 3D => Solids => Box 一步式创建。

这里不再赘述。 

下面从上到下演示新建体的步骤。以下红色件即是新建的几何体。 
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图 创建了管柱的圆柱体 

 

图 逐渐创建圆柱、长方体等 

需要注意的是，因为后续我们将提取这些几何体的外表面画网格，所以需要对这些体做布

尔操作，对内部交叉的部分合并。 

为了方便观察布尔操作前后的差别，首先将几何着色选择为 Topology 模式。然后在 3D 

=> Boolean => Combine 中合并这些体 
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图 几何着色更改  布尔操作 

操作后，可以看到体之间已经合并。 

  

图 体合并前后的差别 

转向系统其余部分操作类似，限于篇幅不再赘述。以下是上述部分划分三角形网格后的效

果。 
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图 转向系统上半部分划分三角形网格效果 

5.2.5 轮毂 

针对下面的轮毂进行示例操作。 

 

图 轮毂几何 

考虑到轮毂辐条的厚度通常相较波长 1/8 小很多，所以只需要提取轮毂的外表面进行几何

面提取。即仅用一层网格来替代整个轮毂的电磁效应。 
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观察该轮毂可以发现局部线条太多，若手动一个个点选势必费时费力，这时候考虑的方法

是，将内外几何断开连接，然后再批量选择。 

首先将轮毂几何体删除，仅保留几何面。 

然后选择轮毂内侧的一圈面断开，如下图。再将辐条内侧和轮圈内侧的连接断开。 

 

图 删除轮毂内外连接面 

断开后，选择任意外表面几何，右键 Select => Attached faces，即可选择外表面 

 

图 选择外表面相连面 
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图 选中的轮毂外表面几何 

选中后，将外表面几何复制到一个新的 component 中，在进行后续的补孔、BatchMesher

操作，可以看其他章节的类似操作，这里不再重复说明。 

5.3 动力总成的建模与连接 

5.3.1 N 合一电驱动/发动机/增程器 

此章将介绍 N 合一电驱动的快速画法，用到的功能是 HyperMesh 中的 2D>Surface 

Mesh>Shrink Wrap 工具。 Shrink Wrap 收缩包络网格划分是针对复杂模型简化处理的方式，

这些复杂模型不需要精细建模，如动力总成的部件。该方法的特点是，仅需选择轮廓零件，

设置好包络方法和网格尺寸后，一键生成复杂零件的轮廓网格。默认生成的面网格包含四边

形和三角形网格，为得到全部为三角形网格，需要再进行网格重新划分。 

1. 打开 HyperMesh,导入几何模型。 

 

图 导入电驱动总成几何模型 
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2. 新建一个空白 component，并设置为当前 component，用于存放后续生成的包络网格。

具体方法为，选中模型树中的 component，右键点击 Create。选中新生成的 Component

重命名为“wrap”，wrap 加粗显示即为当前 component。 

  

图 创建新的 component 

3. 进入 Shrink Wrap 工具，从 HyperMesh 主菜单 2D>Surface Mesh>Shrink Wrap 进入，或

者 Ctrl+F 搜索“shrink wrap”进入。 

从主菜单进入工具 

 

图 Shrink Wrap 工具入口 

从搜索进入： 
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进入工具后将看到如下对话框 

 

图 Shrink Wrap 工具界面 

4. 定义 shrink wrap 对话框参数并生成面网格，包括选择对象、单元尺寸，方法，其他保持

默认 

a) 选择对象，对象选择为轮廓件，比较大的描述轮廓的件，小件例如螺栓不选。 

 

  

图 选择对象 

b) 设置 Shrink Wrap 其他参数，并点击 Mesh 生成面网格 
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图 生成包络单元 

c) 查看 Shrink Wrap 生成的网格，并与几何对比。点击 Mesh 后生成的网格会自动与

几何同时显示，可通过图形区底部的 Show/Hide 工具单独显示网格或几何，查看

生成的效果。 

  

图 单独显示单元或几何 
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5. 查看生成的单元内部情况，尤其注意孔洞位置，如果有内部多余单元，要删除。 

a) 对象切换为 element，按拓展选择器 by face，Angle 设置为 10，选中模型外表面，

点击 Ok, 按快捷键 H 隐藏单元。 

 

  

图 隐藏外表面的单元 

b) 删除孔洞附件的单元，断开内部单元与外部单元的连接。调整视图如下，并框选

单元，按快捷键 Delete，删除内部单元与边面单元的连接位置处单元。 

 

图 删除内外连接单元 

c) 选中 1 个内部单元，按鼠标右键 By Attached 选中所有内部单元，按快捷键

delete 删除选中的单元。按快捷键 A 显示所有的单元。 
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图 选择相连的单元 

6. 用主菜单中的 2D>Surface Mesh>Freeform 重新生成三角形网格。选择所有的表面单

元，设定单元尺寸 15mm，设定 Element type 为 Trias.点击 Mesh。 

 

图 重画网格 

7. 查看生成的三角形网格 

 

图 重画后的三角形网格 
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5.3.2 变速箱 

建议通过 4.1.5 Shrink Wrap 包覆面介绍的方法处理，这里不重复说明。 

5.3.3 传动系统 

传动系统处理方式和 5.2.3 转向系统章节类似，可通过手动创建立方体、圆柱等几何等效替

代原传动系统。这里不再重复说明。 

5.3.4 油箱 

建议参考 4.1.3 手动取表面+几何清理+2D Mesh 的方法处理，这里不重复说明。 

5.3.5 空调压缩机 

建议通过 4.1.5 Shrink Wrap 包覆面介绍的方法处理，这里不重复说明。 

5.3.6 电池包 

电池包内部结构复杂，但对于整车电磁抗干扰来说，由于电池包是金属封闭的，故不关心其

内部的具体结构。从建模上说，我们可以通过类似 5.2.3 悬挂章节中的由线创建面。也可以

箱 5.2.3 转向系统中的创建体来等效电池包几何。 

需要注意的是，电池包上表面通常与车身地板紧贴，故在保留车身地板的情况下，不需要将

电池包上表面建模，仅需保留侧面、底面即可。 

常见电池包的外形： 
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图 电池包外形 

可以手动创建沿着托盘边缘的一圈线条，然后拉伸出电池包的侧面。然后再类似 5.2.3 悬挂

章节由线创建底面，底下和侧面简化几何的最终效果如下。 

 

图 电池包的底面和侧面几何简化 

获取该几何后，可以直接进行 Freeform（HyperMesh2024 版）或 General 2D Mesh

（HyperMesh 2023 版）进行三角形网格划分。也可以通过 BatchMesher 操作，可参考其

他章节操作，这里不再重复说明。 
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5.4 座椅的建模与连接 

首先，要考虑座椅的对称性，参考 4.3 节描述的白车身的对称性，将半边做好之后，镜像过

去。 

.      

图 利用座椅的对称性建模 

至于座椅金属骨架的建模，建议使用 BatchMesher。连接关系可参考 4.2 节中的各种方法

按需使用。汽车座椅钢丝的建模，请参考 4.1.7 小节的说明。 

5.5 电子电器的建模与连接 

5.5.1 线缆 

线缆通过 1d 单元模拟，主要通过 Midline 功能抽取线缆的中线，请参考 4.1.7 小节的内容。 

5.5.2 小蓄电池等 

建议可以直接画个长方体替代，如下： 
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图 小蓄电池等效为一个长方体，取其外表面网格 

5.6 不同子系统之间的连接关系 

汽车整车中，不同子系统之间的连接，大多数采用螺栓固定，螺栓是金属件可以传递电流，

这种情况两个子系统就需要共节点连接。这类连接举例如车身和座椅、车身和减震器，车身

和车门，车身和 IP 横梁，车身和电池包等。 

另外为了保证舒适性（避免振动的直接传递），在某些位置通常会采用悬置衬套进行连接，

这种衬套通常是橡胶材料，无法传递电流，故这些连接位置，两个子系统需要断开。这类连

接，如发动机和车身、某些副车架和车身之间的连接等，需要注意的是，副车架和车身之间

也有硬连接（螺栓连接），只有在舒适性要求较高的车上会用软连接，故若电磁工程师对底

盘结构不熟悉，建议和底盘 DRE 进行确认。 

至于连接方法，可直接参考 4.2 节的 4 类连接方法按需操作。 

6 其他网格尺寸的电磁分析模型 

6.1 更小网格尺寸 6mm，9mm 的电磁分析模型 

使用 HyperMesh => 2D => Freeform，选中所有单元，指定将 15mm 网格重画为 9mm 网

格，选项设置选择三角形网格，如下。 
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图 选择 Trias 生成三角形网格 

 

图 原始的 15mm 网格 
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图 9mm 网格 

接下来，基于 9mm 网格，再次重画为 6mm 网格，如下。 

 

图 6mm 网格 

6.2 更大网格尺寸 25mm，50mm 的电磁分析模型 

可通过 Feko 进行 15mm 网格向更大尺寸网格划分，以 30mm 网格重画为 50mm 为例，Feko

软件导入已有的 30mm 模型的车身模型，选中 Meshes>car_Car_30mm 的网格，点击右键选

Use Model Mesh（Currently not Re-Meshing） 
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图 将网格设置为几何 

重新划分网格模型，点击主菜单 Mesh>Modify Meshing ，弹出  Modify Global Mesh 

Settings 。Mesh size ：Customer； Triangle edge length ：0.05。点击 Automatic Meshing。

Feko 将重新划分 50mm 的网格模型 

 

图 设置网格划分尺寸：0.05 
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图 车身 50mm 网格模型 

选中 Meshes>car_Car_30mm 的网格，点击右键选 Info，弹出 Simulation Mesh info，点击

Histogram，显示网格尺寸分布图。 

 

图 显示网格尺寸分布图 

以上划分的网格，可以在 Feko 中进行试算，如果出现少量网格干涉或连续性问题，可以输

出 Nastran 网格模型，使用 HyperMesh 对模型进行少量修复即可用于计算。 

7 电磁网格质量检查 

7.1 Free edges 自由边检查 

自由边检查工具位于 HyperMesh => Validate => Edges 位置。 
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图 Validate 工具入口 

 

图 某局部自由边检查 

通过自由边检查可以直观地看到模型内部断开连接的位置。一些位置本身是边界，所以有自

由边是正常的，如上如中围成圈的几个自由边。一些位置本身应该是互相连接的，但是产生

了自由边就不正常，如上图中箭头所指位置。 

仔细观察上图中箭头位置，发现是一个缺口，可以通过 2d-edit element-create 工具补上。 

  

图 手动创建单元填缺口 
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7.2 Penetration&Intersection Check 网格交叉检查 

电磁网格的交叉会导致 Feko 求解报错，所以网格划分完成之后，建议进行网格交叉检查。 

该工具入口： 

 

图 Penetration Check 工具入口 

该工具检查两种交叉重叠情况：交叉即网格面互相穿透，重叠即考虑单元厚度的情况下，

厚度方向互相重叠。 

因电磁三角形面片网格无厚度概念，故只需要检查交叉，即 Intersection。 

打开三横线选项按钮，选择检查类型为 Intersections。 

 

图 检查类型选择 Intersection 

为了便于演示，将某局部节点移动，制造网格交叉效果如下 

 

图 网格交叉效果 
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此时，使用 Penetration Check 工具检查，可以看到下图 1 处自动弹出来 Penetration 浏览

器，显示当前存在一处网格穿透。此时点击 2 处 Highlight failed，可将该局部出错位置高

亮显示。 

 

图 Penetration 检查效果 

此时，可以点击 Fix all 自动修复，也可点击导航条右侧的箭头，进行手动修复。下面以手

动修复为例说明。点击右侧箭头后，再次点击 Highlight failed 定位至出错位置，此时导航

条自动会将选择对象切换为节点。 

选择造成交叉问题的节点，软件自动弹出移动工具，用户可以指定方向，按住 Alt 件并使

用鼠标左键移动节点，直到网格不交叉。 

  

图 手动处理交叉问题 

当然，该节点也可以直接通过 F3 功能和右侧件共节点，这里就不再演示说明了。 

 

本文完。如需技术支持或交流，请使用公司邮箱，发送邮件至澳汰尔技术支持

support@altair.com.cn，谢谢！ 
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